PDA

Zobacz pełną wersję : Ikona 'Games' w menu


grzyb
24-08-2009, 10:20
Treść widoczna tylko dla zarejestrowanych użytkowników.

Tak to będzie wyglądać ;D Po wielu próbach udało mi się ikonę uzyskać. Ale nie przedłużając napiszę jak to zrobić.

1: Tworzysz folder Gry w menu
2: Włączamy X-Plore (ew. Y-Browser itp.), plik games.mif wrzucamy do folderu C:/System
3: Następnie przechodzimy do C:\Private\101F4CD2\Content\ i kopiujemy plik appshelldata.xml na kartę pamięci
4: Kopiujemy appshelldata.xml z karty pamięci na pulpit i tam go edytujemy notatnikiem
5: Szukasz linijki short_name="Gry"
6:
Cytuj

short_name="Gry" applicationgroup_name="games" icon_file="C:\System\Games.mif" icon_id="16384" mask_id="16385" icon_skin_major_id="101F86E3" icon_skin_minor_id="1977"/>

Tak powinien wyglądac kod
7: Nie usuwamy niczego co było przed short_name i za nim poprostu tak wklejamy
8: Kopiujemy zmodyfikamyny przez nasz appshelldata.xml do C:\Private\101F4CD2\Content\ i zastępujemy
9: Reset kom i juz mamy zmieniona ikone jesli ja czegos nie zwalilem

Mam nadzięję, że w miarę jasno napisałem, choć operacja jest trochę zawiła. Dodam jeszcze, że nie wpadłem na to sam, a wyczytałem na blogu (poniżej link).

Ikonka do ściągnięcia na blogu:
Treść widoczna tylko dla zarejestrowanych użytkowników.


by grzybiarz91: skopiowałem instrukcję ro0 jako główną, bo jest prostsza i czytelniejsza ;)


by korzenio91: Jeśli po podmianie ikonki znika wam wiele rzeczy z menu , przywróćcie stary plik i utwórzcie nowy folder Gry od nowa , tak aby w pliku appshelldata.xml gry był jako ostatni folder na liście :)

White_Raven
24-08-2009, 10:31
tylko czemu musi być złamany system :( chyba w końcu go jednak złamię.. :]

grzyb
24-08-2009, 10:34
Bo jak nie masz złamanego to nie uzyskasz dostępu do plików systemowych. Choć mam świadomość, że zadałeś pytanie retoryczne, napisałem da potomnych :D

RecoL
24-08-2009, 10:36
no i dla tej ikonki chyba też złamie system :) wielki + :)

ro0
26-08-2009, 00:47
Jakoś sam na to wpadłem i zadziałało
1: Tworzysz folder Gry w menu
2: Włączamy X-Plore (ew. Y-Browser itp.), plik games.mif wrzucamy do folderu C:/System
3: Następnie przechodzimy do C:\Private\101F4CD2\Content\ i kopiujemy plik appshelldata.xml na kartę pamięci
4: Kopiujemy appshelldata.xml z karty pamięci na pulpit i tam go edytujemy notatnikiem
5: Szukasz linijki short_name="Gry"
6: short_name="Gry" applicationgroup_name="games" icon_file="C:\System\Games.mif" icon_id="16384" mask_id="16385" icon_skin_major_id="101F86E3" icon_skin_minor_id="1977"/>
Tak powinien wyglądac kod
7: Nie usuwamy niczego co było przed short_name i za nim poprostu tak wklejamy
8: Kopiujemy zmodyfikamyny przez nasz appshelldata.xml do C:\Private\101F4CD2\Content\ i zastępujemy
9: Reset kom i juz mamy zmieniona ikone jesli ja czegos nie zwalilem

DOWNLOAD
Treść widoczna tylko dla zarejestrowanych użytkowników.
Mam nadzieje że napisałem to jasno i ze P.Kowalski to zrozumie

White_Raven
26-08-2009, 21:38
działa.. o tyle o ile WYMAGA ZŁAMANEGO systemu to raz..

trzeba myśleć przy szukaniu ścieżki.. bo u mnie short_name="Gry" nie znalazło :] więc pominąłem i wkleiłem podany wyżej kod w miejsce gdzie znalazłem folder "GAMES" :]

atrakcyjny
26-08-2009, 22:44
C:\Private\101F4CD2\Content\ i kopiujemy plik appshelldata.xml

po 1. nie mam takiego pliku, mam tylko appshelldata.ini, a po 2. nie chce się skopiować :)

system złamany

Gorgonek
27-08-2009, 07:06
Poza installserver w rompatcherze są jeszcze 2 patche, open4all i ten drugi masz zaaplikowany na czas wykonywania modyfikacji? ;)

maciek1422
27-08-2009, 11:25
A ja nie mam dostępu do katalogu C:/System , a system mam złamany. Normalnie X-plore bez podpisywania zainstalowałem. proszę o pomoc. Jak łamałem system to było trochę inaczej niż na screenach ale nie miałem żadnego błędu. Co mam zrobić???

grzyb
27-08-2009, 12:07
maciek1422 w RomPatcherze weź opcje i Disable caps, powinno pomóc ;)

atrakcyjny, na pewno sprawdzasz w folderze Content? Bo appshell.ini jest, ale bezpośrednio w 101F4CD2... Jak wyżej, daj Disable caps, może pomoże.

maciek1422
27-08-2009, 17:12
Niestety nie pomogło ;( Ale jak hackuje to w RomPatcherze ta pierwsza opcja nazywa się Installserver_fp2_v1.1 a nie ChangeSWIpolicyPath. Może w tym problem? A jeszcze jak Włączam Hellox to to instaluje mi się jeszcze jakieś "modo". Proszę o pomoc.

EDIT:
O wygląda to tak: Treść widoczna tylko dla zarejestrowanych użytkowników. Ktoś mi pomoże co mam zrobić żeby mieć dostęp do plików systemowych?

RecoL
28-08-2009, 08:34
zrobiłem jak ro0 napisał i śmiga wielkie dzięki :)

atrakcyjny
28-08-2009, 08:52
Troche z tym bawienia było ale pomogło, dzięki za pomoc Gorgonek i Grzybiarz.

metoda ro0 zadziałała w 100%! :)

ro0
29-08-2009, 00:34
Maciek a w x-plore masz ustawione aby ci pokazywał pliki systemowe? chodzi o ukryte pliki/foldery systemowe , rom i ram?
Jak nie wiesz jak to sprawdzic to masz instrukcje
Menu-Tools-Configuration- i zaznaczasz ptakiem 4 pierwszy opcje i klikasz back i juz masz

maciek1422
29-08-2009, 10:40
Spoko już wcześniej poradziłem sobie za pomocą Y-browser'a i Recol'a ;)

przemo264
04-09-2009, 20:27
Dzisiaj shackowałem system ze względu na tę ikonkę i wszystko jest ok po za tym, że znika mi ikonka ''Aplikacje''. Czy robię jakiś poważny błąd, bo już sam nie wiem?

RecoL
05-09-2009, 08:07
możliwe że namieszałeś coś w appshelldata.xml :) zrobiłeś na pewno kopię tego pliku więc zrób jeszcze raz jak w poradniku i uważaj żeby nic nie usunąć ani nie pomieszać ;)

przemo264
05-09-2009, 11:02
nie możliwe żebym usunął ikonkę aplikacji tyle razy ile próbowałem to wgrać :(, a było tego trochę ;). Zawsze edytowałem oryginalny appshelldata.xml i kończyło się to albo na usunięciu ikonki ''Aplikacje'' albo na usunięciu ikonki ''Gry'' albo na usunięciu oby dwóch ikonek... Na razie jeszcze trochę się z tym pobawię, jak by co to poproszę jeszcze o pomoc ^-^

_____________________________________________

No i tak jak mówiłem ^-^ Wreszcie mogę cieszyć się ikonką ''Gry'' ;D

HolyGoalie
25-10-2009, 13:59
ulalal ;D Ale kiche zrobiłem :/ Zrobiłem jak napisaliście i poznikały mi wszystkie ikonki ;D ! Mam tylko wiadomości rejestr i gry. A xplore miałem w aplikacjach przez co nie mam do niego dostępu. Jak mogę przywrócić ikonki? oczywiście mam ten plik w normalnej wersji, który modernizowałem ;d

błagam pomocy ! :D

grzyb
25-10-2009, 14:15
Heh, to ciekawie. Szczerze powiedziawszy mi też ikonki nie raz poznikały, ale jako że JbakTaskmana używam tam miałem skrót do x-plore ;D

HolyGoalie
25-10-2009, 14:19
ok ;d udało mi się wyjść z tego bez formata ;]

prezess100
15-11-2009, 16:03
moglby ktos reuploadowac paczke z pierwszego linku? odsiebie juz nie dziala :D

grzyb
15-11-2009, 17:17
W pierwszym poście jest link do blog, stamtąd ściągniesz ikonę.

prezess100
17-11-2009, 19:42
wielkie dzieki za poradnik i za pomoc grzybiarz91

albertoo
27-11-2009, 08:21
wszystko zrobione ok;) + ;)

prezess100
27-11-2009, 08:26
wlasnie, daloby sie domyslnie ustawic ten folder by gry sie tam instalowaly? :)

zbig992
05-12-2009, 23:37
po zrobieniu tej modyfikacji gry będą w nim automatycznie instalowane? czy trzeba będzie je przenosić z aplikacji "na własną rękę"?

prezess100
06-12-2009, 00:22
trzeba przenosic wlasnie...

zbig992
20-12-2009, 00:20
a ja mam jeszcze jedno pytanko: wie ktoś jak samemu stworzyć plik MIF z ikonką? żeby użyć własnej grafiki :)

grzyb
20-12-2009, 19:05
Prawdę powiedziawszy szukałem o tym trochę i nie znalazłem łatwego sposobu na to. Zawsze można wyciągnąć ikonkę z gotowej już aplikacji, jeśli by pasowała z jakiegoś programu.

korzenio91
20-12-2009, 19:20
Treść widoczna tylko dla zarejestrowanych użytkowników. z tego mozna wymłucić ikonke :) program na telefon wymagający pythona konwertuje pliki do mif :)

ctt
15-06-2010, 20:46
U mnie ikona wygląda następująco:
Treść widoczna tylko dla zarejestrowanych użytkowników. miał tak ktoś?:P
EDIT
Było wszystko ok, to wina motywu.

Dulo
25-08-2010, 07:04
Przepraszam, że odkopuję ale mam zainstalowany soft v51.0.006.C6 i nie mam w c:/private/101F4CD2 folderu Content... Mam włączonego Patcha Open4all.

korzenio91
25-08-2010, 08:49
bo C6 tego nie ma to jest tutorial to tuby:)

Dulo
25-08-2010, 08:59
;( Lipa. Może ktoś wymyśli to do C6;/

____________________________


Już udało mi się zrobić tą ikonkę (dzięki Bojar).

Da się dodać poprostu w C6 układ menu ma inna nazwę i jest w innym folderze.

matty_t
28-02-2011, 21:30
Przepraszam, że odkopuje tak stary temat, ale mam problem. Postępowałem zgodnie z poradnikiem, ale zniknął mi folder aplikacje i nie chce się pojawić. Niestety nie zrobiłem kopii tego pliku, ale analogicznie zmieniłem zawartość, więc jest tak jak oryginalna. Jak przywrócić folder aplikacje? Mam dostęp do x-plore.

Gruchi
01-03-2011, 16:14
Treść widoczna tylko dla zarejestrowanych użytkowników.

łap oryginalny pliczek :)

matty_t
01-03-2011, 18:34
Gruchi, dzięki wielkie za pomoc. Wszystko działa tylko mi się ikonki poprzestawiały fabrycznie, ale to szczegół, bo sobie poustawiam. ;) Dodam, że gdy komuś się tak stanie i nie ma dostępu do x-plore itd. to pomocny jest wtedy pasek skrótów gdzie ustawiamy jako skrót x-plore lub coś innego co jest potrzebne i tak wchodzimy na czas kiedy tego nie naprawimy. ;)

Dzięki jeszcze raz, plusik leci.